just4fun
千年狐狸
千年狐狸
  • UID30408
  • 注册日期2009-09-17
  • 最后登录2016-04-28
  • 发帖数1497
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度2点
阅读:4478回复:10

3.7最新的每夜版不能禁用扩展兼容性检查了?

楼主#
更多 发布于:2009-11-11 15:07
如题,刚升级了3.7a1pre的20091110每夜版,发现一堆扩展用不了了。进config一看,extensions.checkCompatibility的false还在,但不起作用了。而安全性检查仍可禁用。

不想一个个扩展去改版本号,只好暂时先装NTT解决了。又多装一个扩展。。。
咪姆
非常火狐
非常火狐
  • UID2913
  • 注册日期2005-02-10
  • 最后登录2019-03-22
  • 发帖数951
  • 经验13枚
  • 威望0点
  • 贡献值0点
  • 好评度1点
  • 社区居民
  • 忠实会员
1楼#
发布于:2009-11-11 15:07
的确如此,而且我发现这几天的版本无法更新实时书签,换回3.6b2则可以


kongou
火狐狸
火狐狸
  • UID12490
  • 注册日期2006-04-26
  • 最后登录2016-12-21
  • 发帖数235
  • 经验12枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
  • 社区居民
2楼#
发布于:2009-11-11 15:07
3.6beta3pre也是。
plumxp
狐狸大王
狐狸大王
  • UID63
  • 注册日期2004-11-22
  • 最后登录2019-01-12
  • 发帖数375
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
  • 社区居民
3楼#
发布于:2009-11-11 15:07
好在我常用的插件就那几个,一个个改支持的最大版本号也不难。
wiiwaker
狐狸大王
狐狸大王
  • UID23532
  • 注册日期2008-04-04
  • 最后登录2019-05-12
  • 发帖数376
  • 经验14枚
  • 威望0点
  • 贡献值4点
  • 好评度0点
  • 社区居民
4楼#
发布于:2009-11-11 15:07
新建一个布尔值,extensions.checkCompatibility.3.7a=false
如果是3.6b3pre的话,后面的3.7a改为3.6b或者3.6都行.
原来的extensions.checkCompatibility没用了.
idragonet
千年狐狸
千年狐狸
  • UID15658
  • 注册日期2006-11-12
  • 最后登录2017-11-15
  • 发帖数2642
  • 经验162枚
  • 威望1点
  • 贡献值74点
  • 好评度118点
  • 社区居民
5楼#
发布于:2009-11-11 15:07
https://bugzilla.mozilla.org/show_bug.cgi?id=521905

This works out like this:

3.6a1 -> extensions.checkCompatibility.3.6a
3.6b1 -> extensions.checkCompatibility.3.6b
3.6b2 -> extensions.checkCompatibility.3.6b
3.6 -> extensions.checkCompatibility.3.6
3.6.1 -> extensions.checkCompatibility.3.6
3.6.1b1 -> extensions.checkCompatibility.3.6


如果你使用Firefox 3.6beta2 那些新建一个布尔值extensions.checkCompatibility.3.6b 设置为false

如果是Firefox 3.7a1 新建一个布尔值 extensions.checkCompatibility.3.7a 设置为false.
kmc
kmc
管理员
管理员
  • UID165
  • 注册日期2004-11-25
  • 最后登录2019-11-21
  • 发帖数9158
  • 经验366枚
  • 威望1点
  • 贡献值116点
  • 好评度38点
  • 忠实会员
  • 终身成就
  • 社区居民
6楼#
发布于:2009-11-11 15:07
我这几天也注意到bugzilla上的讨论了,把绕过版本号做得更困难,估计是已经出现安全方面有隐患的扩展了。

还好就是Mr Tech Toolbox里面的那个Make all compatible还能用。
Waterfox扬长而去
just4fun
千年狐狸
千年狐狸
  • UID30408
  • 注册日期2009-09-17
  • 最后登录2016-04-28
  • 发帖数1497
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度2点
7楼#
发布于:2009-11-11 15:07
看来还是能解决的,谢谢lss了,这就把NTT卸了
mezzano
小狐狸
小狐狸
  • UID6201
  • 注册日期2005-05-21
  • 最后登录2013-07-25
  • 发帖数73
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
8楼#
发布于:2009-11-11 15:07
3.6b3试了,附加组件里还是显示不兼容…
hzhbest
千年狐狸
千年狐狸
  • UID22640
  • 注册日期2008-01-15
  • 最后登录2017-04-06
  • 发帖数1763
  • 经验476枚
  • 威望3点
  • 贡献值414点
  • 好评度89点
  • 社区居民
  • 忠实会员
9楼#
发布于:2009-11-11 15:07
mezzano:3.6b3试了,附加组件里还是显示不兼容…回到原帖

显示还是那样显示,但可以用了。
alan365
小狐狸
小狐狸
  • UID24663
  • 注册日期2008-06-17
  • 最后登录2012-03-25
  • 发帖数3
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
10楼#
发布于:2009-11-11 15:07
继续使用3.5.9的飘过……
游客

返回顶部