dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
阅读:3531回复:15

提醒。给用sync和混用3.6/4.0b的同学。

楼主#
更多 发布于:2010-12-10 19:20
首先我觉得这个问题错的在Mozilla。具体是这样的:

1.我一直用的都是4.0b7和3.6,其中主要是3.6。Sync在3.6的版本是1.5.1,一直用来同步没问题。

2.今天下了个nightly的4.0b8pre,登录了一下后退出删除。之后b7和3.6同步都错误,都是提示sync版本低了。就是选择以本地文件覆盖服务器上的都不行。

3. sync在3.6搜索最新的就是1.5.1,4.0b7是提示点击后打开的是:https://services.mozilla.com/update/

我差点没晕过去:
Firefox Sync add-on

Users of the Firefox Sync add-on should upgrade to version 1.6 beta 1 or higher of the add-on.
Firefox 4 Beta and Nightly Builds (Desktop and Mobile)

Users of these builds should upgrade to one of:

    Nightly builds from December 1 or later.
    Beta 8 or higher (Desktop)

    Beta 3 or higher (Mobile)

这是我发现sync内置后最大的问题!从以前模块化到现在这样,就是说你要同步,就必须更新!而且是整个firefox。这是结合后的问题,还算了。

可是我觉得最严重的是数据不可逆改变是不是先通知用户?我就用b8pre登录一下,之后所有Dec 1之前的sync都不能同步这个账户了,这太霸王了吧。

好吧,我算你更新了数据格式,我不用服务器上面的数据不成?还不成。用本地低版本(但这是正式版哦!)sync居然无法覆盖。这同装完win7后不让你退回xp有什么区别?

大家小心点就是了
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
1楼#
发布于:2010-12-10 19:20
kmc:这已经不是sync第一次这样了,在没有集成之前(Weave)就这个毛病。我不明白的是有什么数据格式这么难兼容,3.x~4.x又没有什么太大的格式改变,至少书签还是sqlite回到原帖

之前我也遇到过,但都是正式版升级的,没想到b8pre直接干掉。。。还不提示
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
2楼#
发布于:2010-12-10 19:20
just4fun:还是xmarks好用回到原帖

哪天它能同步历史我就用了。。。
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
3楼#
发布于:2010-12-10 19:20
现在可以了?那我也试试。。。上次用xmarks还是09年,那时好像不行吧

。。。。。。。。。等我还去试试,直接too large拒绝了。
这个xmarks的技术好像没sync那么深入。我3个月的记录18mb左右的places文件,上传到sync才2.6mb,去掉图标和压缩了。。

还是用sync
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
4楼#
发布于:2010-12-10 19:20
eilern

以前从3.5到3.6的时候,mozilla往places.sqlite文件的moz_bookmarks这个table里添加了一个field,好像是lastmodified。导致从3.6退回到3.5的时候,places.sqlite文件崩溃。这次不知道升级到4.0b8又改了什么。
回到原帖

上传是提取上传的,不是直接复制。不过这不是重点。

我觉得有不可逆操作的时候肯定要询问用户吧,尤其是整个记录。。。
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
5楼#
发布于:2010-12-10 19:20
原因是这个:
(1.6b1) Employ a simpler crypto infrastructure. This provides a newer storage format and requires that all computers connected to the account are upgraded to this verfsion of Firefox Sync or higher.

但不管怎样升级,提醒用户只是第一点,然后删除服务器数据后能倒过去这是第二点,都应该做到(好歹1.5都是realse版)
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
6楼#
发布于:2010-12-10 19:20
在groups上问过后提示说可以reset key解决。
以前firefox跳个票的时间现在可以发布几个正式版了-_-
dindog
千年狐狸
千年狐狸
  • UID30818
  • 注册日期2009-10-24
  • 最后登录2016-12-05
  • 发帖数1180
  • 经验38枚
  • 威望0点
  • 贡献值4点
  • 好评度8点
7楼#
发布于:2010-12-10 19:20
holoM:试试xmarks去.回到原帖

xmarks的历史功能太弱了,仅限书签还可以用用。
以前firefox跳个票的时间现在可以发布几个正式版了-_-
游客

返回顶部