kmc
kmc
管理员
管理员
  • UID165
  • 注册日期2004-11-25
  • 最后登录2019-08-14
  • 发帖数9153
  • 经验360枚
  • 威望1点
  • 贡献值114点
  • 好评度38点
  • 忠实会员
  • 终身成就
  • 社区居民
阅读:4918回复:13

Autoproxy在21里面好像没起作用啊

楼主#
更多 发布于:2013-02-18 14:48
也不知道是goagent的问题还是什么,好像就跟没启用代理一样。点全局模式,把goagent退出,照样能正常上网而不是显示「代理拒绝连接」。

Timestamp: 2013/2/18 14:46:39
Error: node.GetWeakReference is not a function
Source File: chrome://autoproxy/content/requests.js
Line: 463

估计跟这个错误有关,我回滚到旧版Firefox试试。
Waterfox扬长而去
kmc
kmc
管理员
管理员
  • UID165
  • 注册日期2004-11-25
  • 最后登录2019-08-14
  • 发帖数9153
  • 经验360枚
  • 威望1点
  • 贡献值114点
  • 好评度38点
  • 忠实会员
  • 终身成就
  • 社区居民
1楼#
发布于:2013-02-18 14:48
试了下1月27号的Nightly工作正常。这下AP麻烦了,当然,这么久了,也该是更新的时候了。
Waterfox扬长而去
MalcKear
千年狐狸
千年狐狸
  • UID35386
  • 注册日期2011-03-05
  • 最后登录2019-05-23
  • 发帖数1348
  • 经验131枚
  • 威望0点
  • 贡献值16点
  • 好评度10点
  • 社区居民
  • 忠实会员
2楼#
发布于:2013-02-18 14:48
kmc:试了下1月27号的Nightly工作正常。这下AP麻烦了,当然,这么久了,也该是更新的时候了。回到原帖

The New AutoProxy 独立版马上就要登场了~
fang5566
管理员
管理员
  • UID3719
  • 注册日期2005-03-07
  • 最后登录2019-08-16
  • 发帖数18328
  • 经验4678枚
  • 威望5点
  • 贡献值4264点
  • 好评度1041点
  • 社区居民
  • 最爱沙发
  • 忠实会员
  • 终身成就
3楼#
发布于:2013-02-18 14:48
只认 WCM 的 AutoProxy
Firefox More than meets your experience
lonely_8
狐狸大王
狐狸大王
  • UID30273
  • 注册日期2009-09-03
  • 最后登录2019-08-13
  • 发帖数471
  • 经验235枚
  • 威望0点
  • 贡献值72点
  • 好评度71点
  • 社区居民
4楼#
发布于:2013-02-18 14:48
kmc:也不知道是goagent的问题还是什么,好像就跟没启用代理一样。点全局模式,把goagent退出,照样能正常上网而不是显示「代理拒绝连接」。

Timestamp: 2013/2/18 14:46:39
Error: node.GetWeakReference is not a function
Source File: chrome://autoproxy/content/requests.js
Line: 463

估计跟这个错误有关,我回滚到旧版Firefox试试。
回到原帖

定位到那一行,把它改成return Cu.getWeakReference(node);
暂时还可用,虽然不知道有什么影响就是了
xcffl
火狐狸
火狐狸
  • UID37199
  • 注册日期2011-09-09
  • 最后登录2019-06-07
  • 发帖数201
  • 经验157枚
  • 威望1点
  • 贡献值46点
  • 好评度35点
  • 社区居民
  • 忠实会员
5楼#
发布于:2013-02-18 14:48
fang5566:只认 WCM 的 AutoProxy回到原帖

http://g.mozest.com/thread-42031-1-1
貌似是之前项目中的某个成员建立的
f0rest
小狐狸
小狐狸
  • UID30878
  • 注册日期2009-10-29
  • 最后登录2019-08-17
  • 发帖数59
  • 经验54枚
  • 威望0点
  • 贡献值26点
  • 好评度2点
  • 社区居民
  • 忠实会员
6楼#
发布于:2013-02-18 14:48
foxyproxy
kmc
kmc
管理员
管理员
  • UID165
  • 注册日期2004-11-25
  • 最后登录2019-08-14
  • 发帖数9153
  • 经验360枚
  • 威望1点
  • 贡献值114点
  • 好评度38点
  • 忠实会员
  • 终身成就
  • 社区居民
7楼#
发布于:2013-02-18 14:48
MalcKear
The New AutoProxy 独立版马上就要登场了~
回到原帖

这个项目吗?https://code.google.com/p/the-new-autoproxy/
Waterfox扬长而去
wujxin
小狐狸
小狐狸
  • UID23554
  • 注册日期2008-04-05
  • 最后登录2019-08-17
  • 发帖数64
  • 经验16枚
  • 威望0点
  • 贡献值4点
  • 好评度0点
  • 社区居民
  • 忠实会员
8楼#
发布于:2013-02-18 14:48
在2月初的时候就失效了,暂时用foxyproxy,前几楼的那个版本不太好用,不知到时独立版怎么样。
MalcKear
千年狐狸
千年狐狸
  • UID35386
  • 注册日期2011-03-05
  • 最后登录2019-05-23
  • 发帖数1348
  • 经验131枚
  • 威望0点
  • 贡献值16点
  • 好评度10点
  • 社区居民
  • 忠实会员
9楼#
发布于:2013-02-18 14:48

这个项目吗?https://code.google.com/p/the-new-autoproxy/

是的~
作者是autoproxy的维护者之一    slimx
cyfloelxi
小狐狸
小狐狸
  • UID38656
  • 注册日期2012-04-15
  • 最后登录2014-10-01
  • 发帖数9
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
10楼#
发布于:2013-02-18 14:48
lonely_8
定位到那一行,把它改成return Cu.getWeakReference(node);
暂时还可用,虽然不知道有什么影响就是了
回到原帖


请问一下这个怎么改?我在控制台里也看到了这个,定位过去了但是不知道怎么编辑
谢谢
xuanyuan100
小狐狸
小狐狸
  • UID34492
  • 注册日期2010-11-10
  • 最后登录2018-03-23
  • 发帖数22
  • 经验32枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
11楼#
发布于:2013-02-18 14:48
cyfloelxi

请问一下这个怎么改?我在控制台里也看到了这个,定位过去了但是不知道怎么编辑
谢谢
回到原帖

在配置文件夹下的extensions文件夹下找到“autoproxy@autoproxy.org.xpi”,用压缩软件(我用好压可以)打开,chrome/content/requests.js打开,找到463行,换掉
或者用我这个修改过的
附件名称/大小 下载次数 最后更新
autoproxy@autoproxy.org.xpi (187KB)  105 2013-03-03 20:26
cyfloelxi
小狐狸
小狐狸
  • UID38656
  • 注册日期2012-04-15
  • 最后登录2014-10-01
  • 发帖数9
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
12楼#
发布于:2013-02-18 14:48
xuanyuan100

嗯,自己修改好了,可用
不过偶尔会出现下面这个错误
[quote]
Timestamp: 3/6/2013 5:24:29 PM
Error: wnd is null
Source File: chrome://autoproxy/content/requests.js
Line: 184
回到原帖


页面需要刷新一下才会调用代理
zerox
小狐狸
小狐狸
  • UID39540
  • 注册日期2013-05-28
  • 最后登录2013-05-28
  • 发帖数1
  • 经验10枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
13楼#
发布于:2013-02-18 14:48
我换foxyproxy了。AutoProxy那个0518的更新版本,还是时不时的失效,很烦人。

我设置了所有google.com域名走代理,搜索也是只用 google.com,但是搜索的时候还是会一会儿 google.com 一会儿 google.com.hk。有时候则是卡半天,最后来一个RESET,明显的是没启用代理被干扰的现象。

好像特别是https的连接很容易失效。我设置了全局用代理,访问一个论坛,论坛首页显示我的来源IP就是会变,时而国内,时而北美。
游客

返回顶部