pcxfirefox
千年狐狸
千年狐狸
  • UID39042
  • 注册日期2012-06-22
  • 最后登录2018-01-15
  • 发帖数2539
  • 经验1263枚
  • 威望2点
  • 贡献值242点
  • 好评度133点
  • 最爱沙发
  • 忠实会员
  • 社区居民
阅读:4420回复:17

取消Firefox41+ 64位版本插件限制的补丁

楼主#
更多 发布于:2015-09-04 18:22
由于https://bugzilla.mozilla.org/show_bug.cgi?id=1165981,Mozilla已经决定在Firefox41以后的64位版本插件上仅支持Flash,其他任何插件都不予识别,考虑到还有一些插件可能会在x64上用到(比如pdf插件,自带的pdf.js性能和内存控制上不是太好,或者各种ietab/fireie),所以有些人有需求希望取消这个限制,第三方编译版本很容易revert掉这个补丁,在这里我给出官方版本的二进制补丁,这样有更好的通用性。

在目前最新的Fx41 x64、Fx42 x64、Fx43 x64上测试通过

下载链接:
http://sourceforge.net/projects/pcxfirefox/files/Tools/RemoveFx41x64PluginRestrict/

最新喜欢:

fiagfiag AtesterAteste... fang5566fang55...
http://pcxfirefox.wordpress.com/
fang5566
管理员
管理员
  • UID3719
  • 注册日期2005-03-07
  • 最后登录2019-09-15
  • 发帖数18341
  • 经验4690枚
  • 威望5点
  • 贡献值4272点
  • 好评度1045点
  • 社区居民
  • 最爱沙发
  • 忠实会员
  • 终身成就
1楼#
发布于:2015-09-04 18:57
直接运行补丁就会修改官方版本的么?
Firefox More than meets your experience
pcxfirefox
千年狐狸
千年狐狸
  • UID39042
  • 注册日期2012-06-22
  • 最后登录2018-01-15
  • 发帖数2539
  • 经验1263枚
  • 威望2点
  • 贡献值242点
  • 好评度133点
  • 最爱沙发
  • 忠实会员
  • 社区居民
2楼#
发布于:2015-09-04 19:13
fang5566:直接运行补丁就会修改官方版本的么?回到原帖
找到xul.dll就自动改
http://pcxfirefox.wordpress.com/
谷歌大法好
狐狸大王
狐狸大王
  • UID49692
  • 注册日期2015-04-11
  • 最后登录2019-08-06
  • 发帖数305
  • 经验303枚
  • 威望0点
  • 贡献值232点
  • 好评度24点
  • 社区居民
  • 忠实会员
3楼#
发布于:2015-09-05 09:42
NICE
谷歌大法好
狐狸大王
狐狸大王
  • UID49692
  • 注册日期2015-04-11
  • 最后登录2019-08-06
  • 发帖数305
  • 经验303枚
  • 威望0点
  • 贡献值232点
  • 好评度24点
  • 社区居民
  • 忠实会员
4楼#
发布于:2015-09-05 09:48
能不能做成dll文件 ,然后选择一个挂载点挂载到其他dll上面,这样不用每个版本都patch一次。我见有的QQ外挂就是这么做的,选择一个极少更新的dll,然后挂载自己写的dll   寒星随意录里面那个简单的破解QQvip就是这么做的,用msimg32.dll实现的  感觉类似引导器
pcxfirefox
千年狐狸
千年狐狸
  • UID39042
  • 注册日期2012-06-22
  • 最后登录2018-01-15
  • 发帖数2539
  • 经验1263枚
  • 威望2点
  • 贡献值242点
  • 好评度133点
  • 最爱沙发
  • 忠实会员
  • 社区居民
5楼#
发布于:2015-09-05 10:23
谷歌大法好:能不能做成dll文件 ,然后选择一个挂载点挂载到其他dll上面,这样不用每个版本都patch一次。我见有的QQ外挂就是这么做的,选择一个极少更新的dll,然后挂载自己写的dll   寒星随意录里面那个简单的破解QQvip就是这么做的,用ms...回到原帖
不能 内联函数无法被劫持
http://pcxfirefox.wordpress.com/
Atester
狐狸大王
狐狸大王
  • UID45325
  • 注册日期2014-04-03
  • 最后登录2016-09-14
  • 发帖数391
  • 经验358枚
  • 威望0点
  • 贡献值56点
  • 好评度23点
  • 社区居民
  • 忠实会员
6楼#
发布于:2015-09-06 10:55
pcxfirefox:不能 内联函数无法被劫持回到原帖
所以我要每天patch一次?不过无所谓了,为了解决任务栏俩图标的问题我已经做了个注册表每天导入一次了
patch后仍不能运行fireie的插件
Doing good is all our mission!
pcxfirefox
千年狐狸
千年狐狸
  • UID39042
  • 注册日期2012-06-22
  • 最后登录2018-01-15
  • 发帖数2539
  • 经验1263枚
  • 威望2点
  • 贡献值242点
  • 好评度133点
  • 最爱沙发
  • 忠实会员
  • 社区居民
7楼#
发布于:2015-09-06 15:33
Atester:所以我要每天patch一次?不过无所谓了,为了解决任务栏俩图标的问题我已经做了个注册表每天导入一次了
patch后仍不能运行fireie的插件
回到原帖
那你用错了吧 能检测到就能使用
http://pcxfirefox.wordpress.com/
Atester
狐狸大王
狐狸大王
  • UID45325
  • 注册日期2014-04-03
  • 最后登录2016-09-14
  • 发帖数391
  • 经验358枚
  • 威望0点
  • 贡献值56点
  • 好评度23点
  • 社区居民
  • 忠实会员
8楼#
发布于:2015-09-06 22:49
pcxfirefox:那你用错了吧 能检测到就能使用回到原帖
忘了我开了e10s了,e10s下fireie的插件是不能用的
Doing good is all our mission!
img099
小狐狸
小狐狸
  • UID42573
  • 注册日期2013-12-01
  • 最后登录2018-08-22
  • 发帖数9
  • 经验10枚
  • 威望0点
  • 贡献值2点
  • 好评度0点
9楼#
发布于:2015-09-07 03:15
这年头连浏览器也要破解补丁了
谷歌大法好
狐狸大王
狐狸大王
  • UID49692
  • 注册日期2015-04-11
  • 最后登录2019-08-06
  • 发帖数305
  • 经验303枚
  • 威望0点
  • 贡献值232点
  • 好评度24点
  • 社区居民
  • 忠实会员
10楼#
发布于:2015-09-07 10:53
pcxfirefox:不能 内联函数无法被劫持回到原帖
那你能否把这个补丁编译到pcx版本里,并加一个参数 控制下这个限制是否开启,然后我就可以在loader里面加“- 参数”来避免每次都要patch
好人好梦
火狐狸
火狐狸
  • UID26935
  • 注册日期2008-11-06
  • 最后登录2019-08-21
  • 发帖数236
  • 经验73枚
  • 威望0点
  • 贡献值20点
  • 好评度4点
  • 社区居民
11楼#
发布于:2015-09-09 17:09
用X64很久了,似乎没发现有很多不便的地方
zyt123
禁止发言
禁止发言
  • UID51154
  • 注册日期2015-09-10
  • 最后登录2015-09-10
  • 发帖数73
  • 经验2枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
12楼#
发布于:2015-09-10 11:10
用户被禁言,该主题自动屏蔽!
moomin
小狐狸
小狐狸
  • UID35147
  • 注册日期2011-01-26
  • 最后登录2018-05-24
  • 发帖数87
  • 经验43枚
  • 威望0点
  • 贡献值12点
  • 好评度0点
  • 社区居民
  • 忠实会员
13楼#
发布于:2015-09-15 21:11
怪不得,今天想用java,浪费了不少时间.
thresh
小狐狸
小狐狸
  • UID37462
  • 注册日期2011-09-30
  • 最后登录2019-05-06
  • 发帖数55
  • 经验47枚
  • 威望0点
  • 贡献值18点
  • 好评度2点
14楼#
发布于:2015-10-03 02:41
mozilla 现在是各种不知道怎么想出来的决策,这也是重复Netcple末期,想怎么玩就怎么玩了么?这属于一脉相承的疯狂?
上一页
游客

返回顶部