333ywb
小狐狸
小狐狸
  • UID27284
  • 注册日期2008-12-03
  • 最后登录2018-12-12
  • 发帖数25
  • 经验44枚
  • 威望0点
  • 贡献值38点
  • 好评度0点
  • 社区居民
  • 忠实会员
阅读:719回复:5

【已解决】升级到Firefox 62.0 beta18后,UC脚本都失效了,怎么办?

楼主#
更多 发布于:2018-08-19 18:05
今天在线更新了Firefox 62.0 beta18以后,UC脚本都不能用了,怎么修复呢。?
 
 现在已退回原来的版本
fang5566
管理员
管理员
  • UID3719
  • 注册日期2005-03-07
  • 最后登录2018-12-12
  • 发帖数18056
  • 经验4445枚
  • 威望5点
  • 贡献值4164点
  • 好评度967点
  • 社区居民
  • 最爱沙发
  • 忠实会员
  • 终身成就
1楼#
发布于:2018-08-19 23:24
我没用uc脚本,不知道到底什么原因 是原来的绕过方法失效了 还是更新导致扩展失效。不知道他人是否能重现
Firefox More than meets your experience
cinhoo
狐狸大王
狐狸大王
  • UID31676
  • 注册日期2010-01-21
  • 最后登录2018-12-11
  • 发帖数330
  • 经验15枚
  • 威望0点
  • 贡献值0点
  • 好评度6点
  • 社区居民
  • 忠实会员
2楼#
发布于:2018-08-20 00:22
autoconfig.js 启动时已经去掉了Components相关的变量了。。。


这是60.1.0的
Array,ArrayBuffer,Boolean,Cc,Ci,Components,Cr,Cu,DataView,Date,Error,EvalError,Float32Array,Float64Array,Function,Infinity,Int16Array,Int32Array,Int8Array,InternalError,Intl,JSON,Map,Math,NaN,Number,OS,Object,Promise,Proxy,RangeError,ReferenceError,Reflect,RegExp,Set,String,Symbol,SyntaxError,TypeError,URIError,Uint16Array,Uint32Array,Uint8Array,Uint8ClampedArray,WeakMap,WeakSet,WebAssembly,XPCNativeWrapper,clearPref,debug,decodeURI,decodeURIComponent,defaultPref,displayError,dump,encodeURI,encodeURIComponent,escape,eval,gIsUTF8,gVersion,getLDAPAttributes,getLDAPValue,getPref,getPrefBranch,getenv,importFunction,isFinite,isNaN,lockPref,parseFloat,parseInt,pref,setLDAPVersion,undefined,unescape,uneval,unlockPref

这是62.0beta18的
Array,ArrayBuffer,Boolean,DataView,Date,Error,EvalError,Float32Array,Float64Array,Function,Infinity,Int16Array,Int32Array,Int8Array,InternalError,Intl,JSON,Map,Math,NaN,Number,Object,Promise,Proxy,RangeError,ReferenceError,Reflect,RegExp,Set,String,Symbol,SyntaxError,TypeError,URIError,Uint16Array,Uint32Array,Uint8Array,Uint8ClampedArray,WeakMap,WeakSet,WebAssembly,XPCNativeWrapper,clearPref,debug,decodeURI,decodeURIComponent,defaultPref,displayError,dump,encodeURI,encodeURIComponent,escape,eval,gIsUTF8,getLDAPAttributes,getLDAPValue,getPref,getenv,importFunction,isFinite,isNaN,lockPref,parseFloat,parseInt,pref,setLDAPVersion,undefined,unescape,uneval,unlockPref
【 在 hailongchang (novice) 的大作中提到: 】 上了Firefox这艘贼船就很难再下来了,我当年是报着试一试的心态用了下Firefox,当然包括当时一些如日中天的插件,这一用就抛弃IE了。几年过后,发现IE8也还不错,但是就是怎么都用不管,Firefox连同上面的那些插件已经彻底绑架了我的习惯,用别的浏览器觉得巨不爽,包括Chrome
333ywb
小狐狸
小狐狸
  • UID27284
  • 注册日期2008-12-03
  • 最后登录2018-12-12
  • 发帖数25
  • 经验44枚
  • 威望0点
  • 贡献值38点
  • 好评度0点
  • 社区居民
  • 忠实会员
3楼#
发布于:2018-08-20 08:39
cinhoo:autoconfig.js 启动时已经去掉了Components相关的变量了。。。


这是60.1.0的
Array,ArrayBuffer,Boolean,Cc,Ci,Components,Cr,Cu,DataView,Date...
回到原帖
大佬,这个有解决的办法吗?谢谢
cinhoo
狐狸大王
狐狸大王
  • UID31676
  • 注册日期2010-01-21
  • 最后登录2018-12-11
  • 发帖数330
  • 经验15枚
  • 威望0点
  • 贡献值0点
  • 好评度6点
  • 社区居民
  • 忠实会员
4楼#
发布于:2018-08-21 22:55
根据 https://github.com/Endor8/userChrome.js/tree/master/userChrome
config-pref.js 加上
pref("general.config.sandbox_enabled", false);
【 在 hailongchang (novice) 的大作中提到: 】 上了Firefox这艘贼船就很难再下来了,我当年是报着试一试的心态用了下Firefox,当然包括当时一些如日中天的插件,这一用就抛弃IE了。几年过后,发现IE8也还不错,但是就是怎么都用不管,Firefox连同上面的那些插件已经彻底绑架了我的习惯,用别的浏览器觉得巨不爽,包括Chrome
333ywb
小狐狸
小狐狸
  • UID27284
  • 注册日期2008-12-03
  • 最后登录2018-12-12
  • 发帖数25
  • 经验44枚
  • 威望0点
  • 贡献值38点
  • 好评度0点
  • 社区居民
  • 忠实会员
5楼#
发布于:2018-08-22 09:03
cinhoo:根据 https://github.com/Endor8/userChrome.js/tree/master/userChrome
config-pref.js 加上pref("general.config.sandbox_enabled...
回到原帖
谢谢了,按照方法问题已解决
游客

返回顶部