DOSforever
千年狐狸
千年狐狸
  • UID25201
  • 注册日期2008-07-03
  • 最后登录2024-06-14
  • 发帖数1104
  • 经验848枚
  • 威望0点
  • 贡献值742点
  • 好评度22点
  • 社区居民
  • 忠实会员
阅读:3153回复:13

现在 github 对浏览器版本要求这么高了?

楼主#
更多 发布于:2022-11-03 21:03
去 github 下载,Assets 下面的圆圈一直在转,就是不出来下载链接,试过其它 Blink 内核的 Iron 浏览器也不行,我想这大概应该不是浏览器类型兼容性的问题了。后来经别人提醒,他原来 Chrome 67 版也是和我相同现象,后来升级到 80 版就行了。我就试了下 Edge 107 版和 Vivaldi 5.5 版,发觉确实可以了,原来我的 72 版 Firefox 和 Iron 都不行。
操!一个下载页面也做得对浏览器版本要求这么高?
opentiss
千年狐狸
千年狐狸
  • UID16
  • 注册日期2004-11-21
  • 最后登录2024-02-23
  • 发帖数3371
  • 经验65枚
  • 威望1点
  • 贡献值34点
  • 好评度13点
  • 社区居民
  • 忠实会员
1楼#
发布于:2022-11-04 02:02
你的Firefox不能升级一下的么?确实现在都用各种的库与框架,很不好控制,所以有些招聘的JD里直接说要了解与能解决各浏览器间的兼容。
Blogger
Give Up GitHub!

欢迎使用 Areditors

sntp -P no -r 210.72.145.44
DOSforever
千年狐狸
千年狐狸
  • UID25201
  • 注册日期2008-07-03
  • 最后登录2024-06-14
  • 发帖数1104
  • 经验848枚
  • 威望0点
  • 贡献值742点
  • 好评度22点
  • 社区居民
  • 忠实会员
2楼#
发布于:2022-11-04 12:14
opentiss:你的Firefox不能升级一下的么?确实现在都用各种的库与框架,很不好控制,所以有些招聘的JD里直接说要了解与能解决各浏览器间的兼容。回到原帖
不能。老实说自从换了 Quantum 内核后很多扩展不能用了,新的能替代原有的扩展都没找到,Firefox 一个劲地升级真没觉得带来什么好处,反而带来臃肿变慢等问题,比如这个帖子 https://www.firefox.net.cn/read-218168 所说的,升个级都能卡死人,这说明了什么?而各位给出的解决方案居然是用 SSD ?一个简单的升级问题居然是要靠硬件来解决,这不反映了软件设计有问题吗?再一个反面例子就是我 Edge 一直是让它自动升级的,就很明显感觉到第一次 Blank 内核的 Edge 刚出来的时候反应还比较快,随着版本升级,启动越来越慢,越来越卡,所以我就不常用 Edge 了,还是以“轻量级”的“老”版本 Firefox 为主,看到那个帖子所反映的问题,我就更不打算升级了。
还有,对 Android 版的 Firefox 来说,我也从 fennec 版升级到 fenix 版过,但第一次升级居然一点提示都没有就把我原来 fennec 版的收藏和历史都冲掉了?! https://www.firefox.net.cn/read.php?tid=218142 。这也就算了,后来发现居然无法手动安装扩展!而现在 Mozilla 对大陆用户屏蔽 ublock 等扩展的在线安装,那没办法只好退回 fennec 版 Firefox 了。所以诸多原因并不是我们平白无故死守“老”版本,而是新版本实在做得不像样!
fire/fox
火狐狸
火狐狸
  • UID32624
  • 注册日期2010-04-21
  • 最后登录2024-06-13
  • 发帖数176
  • 经验173枚
  • 威望0点
  • 贡献值186点
  • 好评度9点
  • 社区居民
  • 忠实会员
3楼#
发布于:2022-11-05 15:32
DOSforever:不能。老实说自从换了 Quantum 内核后很多扩展不能用了,新的能替代原有的扩展都没找到,Firefox 一个劲地升级真没觉得带来什么好处,反而带来臃肿变慢等问题,比如这个帖子 https://www.firefox.net.cn/rea...回到原帖
SSD,冷启动热启动都是火狐比 chrome、edge 更快一点,火狐升级也没遇到过卡,edge 确实是越来越臃肿。
taoww
非常火狐
非常火狐
  • UID39284
  • 注册日期2013-03-18
  • 最后登录2024-05-21
  • 发帖数637
  • 经验583枚
  • 威望0点
  • 贡献值110点
  • 好评度106点
4楼#
发布于:2022-11-06 15:49
DOSforever:不能。老实说自从换了 Quantum 内核后很多扩展不能用了,新的能替代原有的扩展都没找到,Firefox 一个劲地升级真没觉得带来什么好处,反而带来臃肿变慢等问题,比如这个帖子 https://www.firefox.net.cn/rea...回到原帖
真搞笑,一边说没觉得升级带来什么好处,一边说不升级github上下载不了,这不就是好处?
DOSforever
千年狐狸
千年狐狸
  • UID25201
  • 注册日期2008-07-03
  • 最后登录2024-06-14
  • 发帖数1104
  • 经验848枚
  • 威望0点
  • 贡献值742点
  • 好评度22点
  • 社区居民
  • 忠实会员
5楼#
发布于:2022-11-06 21:59
taoww:真搞笑,一边说没觉得升级带来什么好处,一边说不升级github上下载不了,这不就是好处?回到原帖
我发觉哦,你现在说话挺冲的,像是要吵架,原来我觉得你蛮有趣的,名字也取得挺有趣的,我一直叫你“淘旺旺”,蛮讨人喜欢的。或许你这方面懂得挺多的,知识挺丰富的,但我也不需要你来嘲讽!
回正题:难道就是为了一个能在 github 上下载而升级?为了这点小事而升级?一个下载页面有必要搞得那么高级吗?再说,当然现在不少网站对浏览器确实有一定的要求,而且是分别列出对 IE 是多少版本、对 Chrome 多少版本,对 Firefox 多少版本,而我至今也没听说 github 网站对浏览器有什么要求,我还特意去查了下 https://docs.github.com/en/get-started/using-github/supported-browsers 只是说明了所支持的浏览器类型,但并没有具体到多少版本。当然了,我看他们也是图省事,一句 we recommend using the latest version 就完了。
opentiss
千年狐狸
千年狐狸
  • UID16
  • 注册日期2004-11-21
  • 最后登录2024-02-23
  • 发帖数3371
  • 经验65枚
  • 威望1点
  • 贡献值34点
  • 好评度13点
  • 社区居民
  • 忠实会员
6楼#
发布于:2022-11-07 06:11
DOSforever:我发觉哦,你现在说话挺冲的,像是要吵架,原来我觉得你蛮有趣的,名字也取得挺有趣的,我一直叫你“淘旺旺”,蛮讨人喜欢的。或许你这方面懂得挺多的,知识挺丰富的,但我也不需要你来嘲讽!
回正题:难道就是为了一个能在 github 上下载而升级?...
回到原帖
总之现在大家都依赖这些框架和库了,根本没人真正关心兼容浏览器的具体版本了,所以出了问题一句用最新版本就搪塞过去了。另外,打不开的下载页面你开一下浏览器开发者工具,看一下具体报错信息,可能会更清楚具体原因的,也可以供大家参考,毕竟有些时候开发者也没多少时间精力资源去找特定环境的计算资源去核实验证。
Blogger
Give Up GitHub!

欢迎使用 Areditors

sntp -P no -r 210.72.145.44
alanfly
千年狐狸
千年狐狸
  • UID31035
  • 注册日期2009-11-10
  • 最后登录2024-05-19
  • 发帖数2769
  • 经验580枚
  • 威望1点
  • 贡献值128点
  • 好评度102点
  • 社区居民
  • 最爱沙发
  • 忠实会员
7楼#
发布于:2022-11-07 23:33
升级程序和软件性能没关系吧,升级程序做得不好不代表软件也慢。linux源里的火狐连升级功能都去掉了,用系统源升级更快。
新版本我倒是觉得性能提升了,现在用的扩展也才3个,最重要的快捷键需求通过改firefox源文件实现了。
现在用户基本都保持更新,网站不会花精力照顾老版本的。
白左
千年狐狸
千年狐狸
  • UID34985
  • 注册日期2010-12-29
  • 最后登录2023-11-13
  • 发帖数2039
  • 经验655枚
  • 威望0点
  • 贡献值364点
  • 好评度69点
  • 社区居民
  • 忠实会员
8楼#
发布于:2022-11-10 17:38
网站不兼容怎么办
A。收购网站,让程序员加班兼容自己的远古客户端
B。黑入网站,威胁站长不兼容自己的远古客户端就删库
C。不更新客户端,也不修改客户端,等着哪一天发生奇迹网站突然兼容远古客户端
D。更新自己的远古客户端,成为再也不需要管扩展版本的webext靓仔
E。手动反编译自己的远古客户端,通过惊人的逆向工程能力强行适配网站

这题我会,遇事不决就选C
-いたんですか? -ええ、ずっと
eagle5678
千年狐狸
千年狐狸
  • UID4956
  • 注册日期2005-04-10
  • 最后登录2023-04-02
  • 发帖数1247
  • 经验204枚
  • 威望0点
  • 贡献值120点
  • 好评度3点
9楼#
发布于:2023-04-02 11:27
chatgpt要球才高,
hitsmaxft
非常火狐
非常火狐
  • UID25803
  • 注册日期2008-08-12
  • 最后登录2024-01-13
  • 发帖数740
  • 经验13枚
  • 威望0点
  • 贡献值0点
  • 好评度0点
10楼#
发布于:2023-06-13 21:34
1T 的 ssd 也就 400 块吧. 没理由不升级

Lost in fx...
Cye3s
千年狐狸
千年狐狸
  • UID155
  • 注册日期2004-11-25
  • 最后登录2024-06-05
  • 发帖数1322
  • 经验95枚
  • 威望0点
  • 贡献值34点
  • 好评度14点
  • 社区居民
  • 忠实会员
11楼#
发布于:2024-01-30 15:11
兄弟,时代在前进
旧版总会有CVE安全漏洞的,Chrome也是,我们公司都强制不能用Win10以下了
我很懒...
Cye3s
千年狐狸
千年狐狸
  • UID155
  • 注册日期2004-11-25
  • 最后登录2024-06-05
  • 发帖数1322
  • 经验95枚
  • 威望0点
  • 贡献值34点
  • 好评度14点
  • 社区居民
  • 忠实会员
12楼#
发布于:2024-01-30 15:34
白左:网站不兼容怎么办
A。收购网站,让程序员加班兼容自己的远古客户端
B。黑入网站,威胁站长不兼容自己的远古客户端就删库
C。不更新客户端,也不修改客户端,等着哪一天发生奇迹网站突然兼容远古客户端
D。更新自己的远古客户端,成为再也不需要管扩展...
回到原帖
加个选项:遇到不能解决的问题,就解决提出问题的人
我很懒...
Cye3s
千年狐狸
千年狐狸
  • UID155
  • 注册日期2004-11-25
  • 最后登录2024-06-05
  • 发帖数1322
  • 经验95枚
  • 威望0点
  • 贡献值34点
  • 好评度14点
  • 社区居民
  • 忠实会员
13楼#
发布于:2024-01-30 15:41
要是不怕安全问题,接着用呗【手动狗头】

https://avd.aliyun.com/product?prod=MozillaFirefox&page=1


第 1 页 / 57 页  •  总计 1704 条记录
我很懒...
游客

返回顶部