jywj108
小狐狸
小狐狸
  • UID37679
  • 注册日期2011-11-04
  • 最后登录2016-06-13
  • 发帖数35
  • 经验43枚
  • 威望0点
  • 贡献值34点
  • 好评度0点
阅读:1972回复:6

地址栏 搜索引擎图标

楼主#
更多 发布于:2016-06-09 15:52
昨天把firefox升级到v47.0,重启后发现omnibar扩展不能用了,带来最严重的后果就是地址栏当前所使用的搜索引擎图标不显示了,根本不能方便的知道当前使用的是哪个搜索引擎,很不方便。诸位有没有什么解决方案。
aaaa007cn
千年狐狸
千年狐狸
  • UID23968
  • 注册日期2008-05-03
  • 最后登录2022-03-07
  • 发帖数1924
  • 经验1138枚
  • 威望1点
  • 贡献值232点
  • 好评度164点
1楼#
发布于:2016-06-09 16:29
退回旧版咯
liuxb
非常火狐
非常火狐
  • UID26160
  • 注册日期2008-09-05
  • 最后登录2021-12-02
  • 发帖数659
  • 经验324枚
  • 威望0点
  • 贡献值184点
  • 好评度16点
2楼#
发布于:2016-06-09 20:16
我也遇到了,修复如下:
chrome\omnibar\content\browserOverlay.js
函数开头增加一行
const VERSION = Services.appinfo.platformVersion;
后面63行,改为
document.getElementById("omnibar-in-urlbar").setAttribute('class', 'v'+VERSION.split('.')[0]);
测试通过。
我的...
jywj108
小狐狸
小狐狸
  • UID37679
  • 注册日期2011-11-04
  • 最后登录2016-06-13
  • 发帖数35
  • 经验43枚
  • 威望0点
  • 贡献值34点
  • 好评度0点
3楼#
发布于:2016-06-09 22:31
liuxb:我也遇到了,修复如下:
chrome\omnibar\content\browserOverlay.js
函数开头增加一行
const VERSION = Services.appinfo.platformVersion;
后面63...
回到原帖
我按照你的回复修改了xpi文件,但是每次安装都提示“似乎文件损坏”,我使用的是记事本编辑的,保存时选择UTF-8,不知道是否是因为这个原因?
可否把你修改的xpi分享一下,谢谢
liuxb
非常火狐
非常火狐
  • UID26160
  • 注册日期2008-09-05
  • 最后登录2021-12-02
  • 发帖数659
  • 经验324枚
  • 威望0点
  • 贡献值184点
  • 好评度16点
4楼#
发布于:2016-06-10 02:20
jywj108:我按照你的回复修改了xpi文件,但是每次安装都提示“似乎文件损坏”,我使用的是记事本编辑的,保存时选择UTF-8,不知道是否是因为这个原因?
可否把你修改的xpi分享一下,谢谢
回到原帖
xpinstall.signatures.required;false
关了签名检查,应该就可以了。
我的...
aaaa007cn
千年狐狸
千年狐狸
  • UID23968
  • 注册日期2008-05-03
  • 最后登录2022-03-07
  • 发帖数1924
  • 经验1138枚
  • 威望1点
  • 贡献值232点
  • 好评度164点
5楼#
发布于:2016-06-11 10:40
目前计划是 48 移除 xpinstall.signatures.required(硬生生从 44 推迟到目前的 48)
还是赶快 fork 下然后去 AMO 签名吧
jywj108
小狐狸
小狐狸
  • UID37679
  • 注册日期2011-11-04
  • 最后登录2016-06-13
  • 发帖数35
  • 经验43枚
  • 威望0点
  • 贡献值34点
  • 好评度0点
6楼#
发布于:2016-06-13 17:57
我找到一个功能基本和omnibar相同,并兼容firefox 47的扩展:Foobar,凑合着用吧
游客

返回顶部